FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation 500 Internal Server Error
#1
Hi,

I seem to be having problems getting past step4.php of the FormTools v2.0.0-beta-20090131.

When I look at the config file it creates the necessary data, but it when I click on the 'Create File' button I get a 500 Internal Server Error page that looks like this: http://www.somedomainname.com/ft2/install/step5.php.

It seems that there is a memory allocation error somewhere as evident from my error log files below:

Code:
somedomainname.com [Fri Feb 06 10:46:41 2009] [error] [client 90.192.XX.XXX] Allowed memory size of 32 bytes exhausted (tried to allocate 56 bytes), referer: http://www.somedomainname.com/ft2/install/step4.php
somedomainname.com [Fri Feb 06 10:46:41 2009] [error] [client 90.192.XX.XXX] Premature end of script headers: step5.php, referer: http://www.somedomainname.com/ft2/install/step4.php

I'm not sure if there is a bug somewhere, but I just wanted to let you know just in case. In the meantime, I'll see if I can figure something out by looking into the php.ini settings.

Regards,
antonitus
Reply
#2
Strange bug! 32 bytes is nothing at all!

I did some Googling, and this thread may be of interest...
http://www.linuxquestions.org/questions/...rt-680048/

A person was encountering the same problem because the memory limit was set to 32 rather than 32MB in their php.ini file.

Any help...?
Reply
#3
Before adding a new thread, I added a php.ini file with the following information:

Code:
upload_max_filesize = 10M

memory_limit = 10M

I did not leave the 'M' out and still it did not work.

After reading your response, I increased the memory limit from 10M to 100M and it seemed to work. Why didn't I do this before I added the thread? I suppose the reason why I didn't do it was because 10M would be sufficient, ... very strange. I suppose computing as a whole is strange.

Thank you for your help with this.

Regards,
antonitus
Reply
#4
Haha yes, computing is a strange world.

Just one things that struck me: you'll probably want to set it to 100MB not 100M. I think what may have happened is that it's still reading it as 100bytes, but now that's OVER the 56bytes needed to load the page. You should probably set it to 30MB not 30M.

Anyway, good luck with it!
Reply
#5
It's fine now. I think the normal practice is having 'M' instead of 'MB. I've used this setting a hundread times when developing upload and download functions.

Thanks for your help.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)