FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Memory error on form submit
#1
Hi

I have installed form tools many times on different servers and never had an issue like this.

I have a shared hosting account, with formtools on one domain and the form itself on another. The formtools install is working fine, its let me setup the form, define all the fields etc. However once I try and submit the form I am getting a memory error:

Fatal error: Allowed memory size of 104857600 bytes exhausted (tried to allocate 35 bytes) in /usr/www/users/wildweb/forms/process.php on line 193

I have had the php memory limit pushed up to 100mb by my host (it was originally on the default 16mb) I have tried doing a clean install again and still have the same issue. Is this a problem with my host ?

As I say formtools admin section is fine, behaving 100% normally. I only get this error when a form gets submitted. I also tried simplifying the form down to just a few fields, and still got the same error.

Any suggestions ?
Reply
#2
Hi Troopa,

Uh-oh, that doesn't sound good... Form submissions shouldn't take much memory at all - they're just "dumb" insertions into the database. There may be additional processing such as sending emails and pre-processing the incoming data, but nothing that should take that amount of memory.

Most larger apps required 64MB - some 128, but 100MB for Form Tools should really be fine. In your case, something's not right: that error message indicates that it's exhausting the entire 100MB of memory while attempting to allocate a mere 35 bytes. Weird...

Do you have any email templates for the form? Could you try temporarily disabling them? How about Submission Pre-Parser, or Hook Manager module scripts - do you have any set up for that form? If so, disable them too.

Tricky to know what to suggest... let me know!

- Ben
Reply
#3
Hey Ben,

Thanks for the reply. Still stuck, I tried deleting the email template I had set and I have disabled all the modules to see if that would make a difference.

I think I am just going to have to code a php mail script and not use formtools on this server for the time being.
Reply
#4
Hi Troopa,

That's a shame! But it's certainly an option.

If you'd like me to look at it, email me at ben.keen@gmail.com with the following info & I could log on and debug it directly:
- temporary FTP info
- the URL of your form & Form Tools installation & your FT login info.
- a link to this thread so I don't lose track

Ben
Reply
#5
I am having the same problem. I added a php.ini file to the form tools directory and set the values to this:
upload_max_filesize = 10M

memory_limit = 10M

Then the same issue occured with the global/code/administrator.php

I added a php.ini there as well, but it's still giving the error.

HELP!
Reply
#6
Hi Lee - I just emailed you. Let me know!

- Ben
Reply
#7
Shocked 
Hi,
I have this error when using a new form.i red the documentation:
Before trying to put through your test submission, you should get your form working with this function. Add this PHP code to top of the FIRST page in your form (even if it's a single page form):

<?php
require_once("../global/api/api.php");
$fields = ft_api_init_form_page("", "test");
?>

my problem is that i dont now where should i copy this cod.
Please help me.
Reply
#8
possibly a related problem here...

i get this message whenever i try to edit a database listing using view submissions.

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 72 bytes) in /var/www/htdocs/formtools/global/code/submissions.php on line 610

i also sent this in as an email, ben

thanks

bill

Reply
#9
Hi Bill,

As per my email, check out this post:
http://forums.formtools.org/showthread.p...mory_limit

I've been working on improving the speed of a few core pages (the submission listing & the edit submission page especially), which is part and parcel with reducing the memory allotted. Ultimately I want to review the whole script to minimize memory usage, but that'll be down the road.

All the best -

Ben
Reply
#10

That fixed it, thanks!

upped the php.ini mem limit to 64M


bill

(Dec 18th, 2010, 9:57 AM)Ben Wrote: Hi Bill,

As per my email, check out this post:
http://forums.formtools.org/showthread.p...mory_limit

I've been working on improving the speed of a few core pages (the submission listing & the edit submission page especially), which is part and parcel with reducing the memory allotted. Ultimately I want to review the whole script to minimize memory usage, but that'll be down the road.

All the best -

Ben

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)