FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Warning: set_time_limit() has been disabled
#1
alright.. bout to reveal myself as a dumb-shit.. haha...

what does
"
Warning: set_time_limit() has been disabled for security reasons in /home/www/theotherday.com.au/form3/formtools/global/code/forms.php on line 883
{ success: 1, message: "" }"

has this got something to do with the php INI file settings ?

I get this on install step 5

cheers

Alex
ok.. so it was.. I delted that from the ini file..

just wondering if someone can explain why that would be set like that.. does this cause any security implications ?

cheers
Reply
#2
Hey Alex,

Welcome to the forums!

Yes, it does have security implications, but it's debatable as to what extent disabling it really helps... Your server prevented PHP scripts using the set_time_limit function because technically, some evil hacker like myself could come along and set it to, say, 1 year, then do something ee-vil, like send a single mail() request to send a few hundred thousand spam.

But you should never see that warning so I'll mark it down as a bug. It's as easy fix to prevent it showing up.

Thanks!

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)