FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mysql Install problem
#1
Hi there
I'm excited to try the new beta form tools
however, I'm running into install probs

See here:

The following error occurred:


• You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8' at line 6

Please double-check your database settings and click the Continue button again.

I'm using 1and1.com and the server MySQL Database provided by 1&1 is 4.0.25

Any tips ?
Reply
#2
Hey tizzo,

I think the problem may be the SQL syntax. I just compared FT1 with FT2 and there's a minor difference for the form creation syntax. The new one uses the term "ENGINE" to define the database type, whereas the old one uses "TYPE".

I've attached a new file to this email. Upload it to your server and overwrite the old /install/files/sql.php file. Then try a fresh installation.

My hunch is that this will fix it, but let me know either way!

- Ben


Attached Files
.php   sql.php (Size: 21.3 KB / Downloads: 15)
Reply
#3
I get the same error even after using the new sql.php file.

"The following error occurred:

• You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8' at line 6"




(Mar 26th, 2009, 9:18 PM)Ben Wrote: Hey tizzo,

I think the problem may be the SQL syntax. I just compared FT1 with FT2 and there's a minor difference for the form creation syntax. The new one uses the term "ENGINE" to define the database type, whereas the old one uses "TYPE".

I've attached a new file to this email. Upload it to your server and overwrite the old /install/files/sql.php file. Then try a fresh installation.

My hunch is that this will fix it, but let me know either way!

- Ben
Reply
#4
I get the same error after using the new sql.php file too
Reply
#5
All I did was change privileges on the connecting database user to strictly localhost and Voila! no further issues.
I'm guessing the install script doesn't like database users with Global or All privileges.
Reply
#6
I have the same issue: "You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8' at line 6"

I created a new DB user with only R/W - still no go. I don't have an option in my hosts CP for localhost only.

And I tried the new sql.php file also.

Any ideas?

Thanks. Bill
Reply
#7
I see that this was given no resolution to some. I had the same problem and I resolved it as follows:

Open the file /install/files/sql.php

Replace every instance of DEFAULT CHARSET=utf8 and DEFAULT CHARSET=latin1 for a blank space. In other words, delete every instance above.

Upload the file to your server, and try to install again.

For your convenience, I've uploaded the file I used.

As I said, this worked for me.

Good luck,
Rodrigo


Attached Files
.php   sql.php (Size: 20.75 KB / Downloads: 5)
Reply
#8
Hi Rodrigo,

Thanks for this. I'm going to log it as a bug. Most databases allow for UTF-8, but the installation script should at least provide the option of a different charset if it's not installed.

Thanks for the post + fix.

- Ben

[EDIT: bug logged here - http://bugs.formtools.org/index.php?cmd=view&id=224]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)