FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Submission Pre-Parser not showing all rules
#1
First of all would like to say, what a great tool you've developed. Formtools has been an awesome find.

Just wanted to report that for some reason i'm only able to see the first 10 Submission Pre-Parser rules when using the module. I've worked around it by adding the rules via the module and then editing them via my Webmin MySQL interface which is no problem, but would be nice not to have to. I've tried changing "Num rules listed per page" in settings of the module, but whether I go up or down it doesn't take effect.

I'm using all of the latest updates of ft and the modules and have run the database integrity without errors.

Any ideas?
Thanks again for a really great tool
Submission Pre-Parser version 1.0.0
Reply
#2
Hi oneidprod,

Huh! Sounds like a bug. I'll try to look at it today - I'll post back later.

- Ben
Reply
#3
Hey oneidprod,

Sorry it took so long to get to this. I just released a fix. Just upgrade your version to 1.0.1 - that'll fix it up! Smile

- Ben
Reply
#4
I know this is an old post, but I'm bumping because I have the exact same problem in 2.1.4 - and the module is the most recent also. I can change the number of rules per page in the settings and the pagination function is affected, but the actual number of rows displaying stays at 10. I currently have 18 rules, and when I set it to show 100 rules per page the pagination knows there is not multiple pages and doesn't display, but I still only see the first 10 rules. When I change it back to 10, I see the same rules but pagination is back and let's me flip through to see them all. I have all my other settings set to show 100 entries per page and would really like this to work on the submission pre-parser list as well.

Is there anything I can do locally to fix this?
Reply
#5
Hi Kevin,

I'll look at this right now. I'll post back in a few mins.

- Ben

[EDIT: yup! It's a bug. I'll release 1.1.2 in a few minutes. Sorry for the wait, Kevin!]
Reply
#6
Thank you so much, Ben! I'm going to make the upgrade in a few minutes. I really appreciate your due diligence on that issue!
Reply
#7
I just completed the upgrade and the fix works! I did, however, find one small bug. Prior to changing the number of items to be displayed, the last page I looked at in my list of rules was Page 2, showing rules 11-20. When I changed my rules per page from 10 to 100, then went back to view the rules, it still showed me page 2, which is now blank, because it's only showing 101-200. Pagination was also removed. I had to go change my default value back to 10, then set my last viewed page as Page 1, then change it back to 100 to see my current rules.

I hope this makes sense. Small bug, most people may not even be affected, but I wanted to report it nonetheless. Thanks again!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)