FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't complete installation step 3
#1
When I try to set up, I can't complete step 3.

The error displayed is • INSERT INTO ft_accounts (account_id, account_type, account_status, timezone_offset, login_page, menu_id) VALUES (1, 'admin', 'active', '0', 'admin_forms', 1) - Field 'username' doesn't have a default value.
Reply
#2
Interesting! Is this with the 2.1.0 beta or the current release?

It looks like maybe you have strict mode - or something else of that nature running on your database.

- Ben
Reply
#3
It's the current release.
Reply
#4
MySQL mode information
'STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE_USER'
Reply
#5
Turned out it was indeed a mode problem.

http://thilinaonline.wordpress.com/2010/...indows-xp/
Reply
#6
what do you mean by 'mode problem'? I actually got the same poblem an d don't know how to solve it. it reads:

The following error occurred:

• INSERT INTO ft_accounts (account_id, account_type, account_status, timezone_offset, login_page, menu_id) VALUES (1, 'admin', 'active', '0', 'admin_forms', 1) - Field 'username' doesn't have a default value

Please double-check your database settings and click the Continue button again.
Reply
#7
Hey guys,

I'm going to fix this with 2.1.0, but probably not 2.0.6. Strict mode isn't that common, and I think it's fair to require it to be off.

- Ben
Reply
#8
Hey victory,

Sorry, that last remark of mine wasn't terribly helpful! To fix it, you should be able to just add this line to your /global/code/general.php file at line 45:

Code:
@mysql_query("SET SQL_MODE = ''", $link);

It should appear right after these two lines:

Code:
if ($g_unicode)
    @mysql_query("SET NAMES 'utf8'", $link);

Let me know if that fixes it for you.

All the best -

- Ben
Reply
#9
Thanks for your response but it still did not work. I got this error:

The following error occurred:

• INSERT INTO ft_accounts (account_id, account_type, account_status, timezone_offset, login_page, menu_id) VALUES (1, 'admin', 'active', '0', 'admin_forms', 1) - Field 'username' doesn't have a default value

Please double-check your database settings and click the Continue button again.
Reply
#10
Hi Victory,

Weird... that worked for me! And change I get could get temporary access to your installation (FTP + Form Tools access) so I could log on and debug the problem directly? If so, send me an email at ben.keen@gmail.com containing your FTP information and Form Tools login information.

- Ben



Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)