FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Google map won't list
#1
Been over and over it to the point where I'm probably looking right at the problem ~ but can't find it for looking.

Everything was installed in formtools/modules/field_type_google_maps/. Added in via Edit Form, added the field, used "Google Maps" in the field type, and much more..

I should note this is an existing form with 40+ submissions.
In the "Edit Submisasion", Google Maps does not show up, but it's in the Forms > Fields.

Using Beta 2.1.0

Is there something else that I missed that I should have installed? I have all the standards that came bundled in 2.1.0


Also, when I go to Modules > and 'Select' "Google Maps Field" I get the following:
Quote:This module doesn't have a configuration section. See the online documentation for more information

TIA
I
Reply
#2
Hi Internaut,

I just released 1.0.3 which includes some better error handling. Maybe give that a go and let me know how it goes!

After installing it and setting a field to use the Google Maps field, you should see it when editing a submission - there's nothing more to it. So if you don't, either you don't have an internet connection (which is obviously needed to connect to Google's servers for the map info) or there's a bug!

- Ben
Reply
#3
(Aug 8th, 2011, 6:46 PM)Ben Wrote: Hi Internaut,

I just released 1.0.3 which includes some better error handling. Maybe give that a go and let me know how it goes!

After installing it and setting a field to use the Google Maps field, you should see it when editing a submission - there's nothing more to it. So if you don't, either you don't have an internet connection (which is obviously needed to connect to Google's servers for the map info) or there's a bug!

- Ben

Hi Ben,

The Map works 80% better now with Google Maps 1.0.4 installed.
Each submission now shows the Google Map of North America.

Entering an address/Update only causes the map to shift slightly, but remains a map of N.A.
Zooming about 14x takes one close to address - but there is no marker and it's only close.

Working on installing today's core, I think it's 20110808 - when you say "today", in which timezone is today? Smile
Reply
#4
Hah, sorry - I'm on "East Coast US time"... whatever that is... try the latest 20110809 version.

And regarding the Google Maps, I agree about the icon... *sigh*.

Okay, as soon as I get a moment I'll release a new version that places a marker at the address. Stupid of me not to include it in the first version sooner, quite honestly.

- Ben

Reply
#5
Hey Internaut,

This one was bugging me, so I fixed it right away. Sorry for so many releases in such a small time span - I didn't intend things to get this agile...!

Try the latest version (1.0.5). I'm hoping that it'll get you up to working 100%.

1.0.5 includes the following:

- improved error handling.
- now shows icon to clearly show the address (icon only appears if address is specified).
- usability update. Clicking <enter> in address field updates the address on the appropriate map, rather than submitting the form.
http://modules.formtools.org/field_type_...wnload.php

Now back to other work!

(But please do let me know of any other issues that you spot).

- Ben
Reply
#6
(Aug 9th, 2011, 5:46 PM)Ben Wrote: Hey Internaut,
.................
Try the latest version (1.0.5). I'm hoping that it'll get you up to working 100%.

1.0.5 includes the following:
.......................
(But please do let me know of any other issues that you spot).
- Ben

New
Sory Ben, but new error. "Stack overflow at line 27" (last one was line 26 - you fixed.)

Procedure to get there:
Click to edit submission.
Put address in Google map textbox. Click "Update" - the screen changes, and the map that is North America disappears with the error popup.
Click OK, and we are returned to the page, but a blank instead of the map.

NOTE:
  • I upgraded the core from:
    FormTools2.1.0-beta-20110730 to today's
    FormTools2.1.0-beta-20110809
  • Google Maps from:
    field_type_google_maps1.0.2 to
    field_type_google_maps1.0.5
Reply
#7
Oh drat...! Smile

Unfortunately I don't have access to any version of IE right now, so I can't reproduce it. My computer died and took my VMWare & Windows VMs along with it. And my installation disks are back in Canada.... *sigh*.

I'm afraid this will have to wait.

- Ben
Reply
#8
(Aug 10th, 2011, 7:11 AM)Ben Wrote: Oh drat...! Smile

Unfortunately I don't have access to any version of IE right now, so I can't reproduce it. My computer died and took my VMWare & Windows VMs along with it. And my installation disks are back in Canada.... *sigh*.

I'm afraid this will have to wait.

- Ben

I must be as crazy as some say - because I am certain I replied to this already. Anyway, problem corrected after upgrading everything.

You did back up your Win VMW and VMs - right? Wink
Reply
#9
Excellent - no more problems at all?

And yeah.... sure I backed up my VMs.... Wink

Well, no. Over the years I've become diligent about constantly backing up my code - but not my environments. Oh well, live and learn. The moral of this story is: don't have cats.

- Ben
Reply
#10
[/code][/quote]
(Aug 12th, 2011, 6:47 AM)Ben Wrote: Excellent - no more problems at all?
None with the map - just looking to see how, or if, one can change or pre-set the default map zoomed in. Was reading your response to Hannes about coordinates and you mention zoom levels. Searched the scripts but can't find where to set that so when a map is displayed, it is zoomed to the pre-set.

You said "The Google Maps field type stores all information in the database field in the following format:"
Code:
street address here|longitude, latitude|zoom level
I've probably been looking right at it and can't see it for looking - it's the cats fault.

Quote:And yeah.... sure I backed up my VMs.... Wink
.......... The moral of this story is: don't have cats.
- Ben

People don't have cats - cats have people.

I
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)