FORUMS


The Form Tools forums are no longer active, but the old posts have been archived here. Please see the Help page on how to get help / report issues.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
File Upload Guidance
#1
Hello everyone,

I just discovered form tools and i have to say, pretty interesting platform based on a pretty interesting idea.

After playing a bit with it i have started getting the hang of it. I have on small question though that i would like some clarification if possible. I have created a multi-page form using the api. All great so far and no problem. I have an upload field where i want the users to be able to upload an image. One of the pages of the multi-page form is a review page. I can see the name of the file uploaded there and also when i go to edit a submission view, the name of the image is there as a link with the delete button next to it. All seems ok. However in the file - > settings area it says that the images will be uploaded in the upload folder on the server. The folder doesnt contain any of the images brwosed from the file upload field. and the link in the edit submission re directs to a Not Found page since the image is not in the upload folder.

Hopefully it has been understood what i am trying to say Big Grin

Any clues? am i missing something?
Permissions etc are all fine.
Reply
#2
Hi ftsakonitis,

Whenever I have file-upload problems, first thing I always test is uploading a file to any submission already in the DB via the Edit Submission page in Form Tools. If that works, it means it's a problem on your form; if it doesn't, if means there's a configuration problem with the file upload settings.

Maybe give that a go and let me know!

- Ben
Reply
#3
(Sep 12th, 2010, 9:42 AM)Ben Wrote: Hi ftsakonitis,

Whenever I have file-upload problems, first thing I always test is uploading a file to any submission already in the DB via the Edit Submission page in Form Tools. If that works, it means it's a problem on your form; if it doesn't, if means there's a configuration problem with the file upload settings.

Maybe give that a go and let me know!

- Ben

Ok i followed your instructions from the edit submit page and the file was uploaded. Therefore the problem is in my form. It is a bit weird though since if i make a submission from my form a refence to the file exists with its name, it just doesnt get uploaded. From your experience do you happen to have an idea regarding this matter?

Thanks in advance for any help provided.
Reply
#4
Hi ftsakonitis,

The usual culprit is that your <form> tag doesn't contain an enctype="multipart/form-data" attribute. That's required in order to tell the server that the form contains one or more files. Any help...?

- Ben
Reply
#5
(Sep 15th, 2010, 5:46 PM)Ben Wrote: Hi ftsakonitis,

The usual culprit is that your <form> tag doesn't contain an enctype="multipart/form-data" attribute. That's required in order to tell the server that the form contains one or more files. Any help...?

- Ben

Hey, thanks for the info, i am going to have a look at it during the weekend and post back.
Reply
#6
Well no luck. Also it seems that when i add a new form the step where there is a smart fill button to identify the fields doest get past index file. Meaning i have a multipage form with index.php, step2.php, step3.php and step5.php.

Is it possible for me to upload my files and perhaps someone could have a look and see what the problem is with the upload file. At first my upload field would get the name of the file but the file wouldnt get uploaded to the server and now after playing around with it the upload field doesnt seem to work at all.

So can i upload my 4 form files and someone could help me out?
Damn.

Never Mind Fixed it.
Everything works perfectly great now.

One small thing i have a review page in the multi-page form and the content of the input file field says "Array" instead of the name of the file.
Reply
#7
Quote:One small thing i have a review page in the multi-page form and the content of the input file field says "Array" instead of the name of the file.

Nice! Sounds like a bug. But I wouldn't worry - that doesn't happen with actual submissions; it's probably just a glitch with the Add Form pages.

What was the problem btw? Just something silly or was something unclear? (Always good to know - the documentation always needs work....!)

- Ben
Reply
#8
is it possible to show the uploaded picture directly in the table that one views instead of the name of the uploaded file?
Reply
#9
Not yet! But yes, in version 2.1.0.

Once I've finished off the other 149187 things on my list for the current 2.1 Alpha, I'll be writing a Image Upload module to do just this. It'll work like file uploads, except it also creates thumbnails and lets you use them on the Submission Listing page instead of just the filename.

Pop back in a couple of months. :-)

- Ben
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)